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Data Item Definitions: 
 

Accounting Month The accounting period of the transaction, i.e. 
the 7th accounting period is the month 07, 
which is January.  The accounting period starts 
at 01 in July.  The state has 13 accounting 
periods, which includes the final period, the 13th 
month, which is used for year-end GAAP 
adjustments, not lapse transactions.  The 
SAAS name for this field is fiscal month. 

Accounting Year The accounting year is July 1 through June 30.  
The SAAS name for this field is fiscal year. 

Agency Nbr (SAAS) A SAAS three character field that associates an 
agency with each transaction. 

Agency Nm (SAAS) The SAAS name assigned to each agency. 

As Of Month A calculated field within MERLIN that converts 
the fiscal month to a calendar month and the 
fiscal year to the calendar year.  Note that 
transactions, which occur in July, August, or 
September for the previous budget year, are 
applied to the month of June.  For example, the 
As of Month for January 2000 would be 
entered: 200001. 

Budget Year Consists of the twelve months of the Fiscal 
Year (July 01 through June 30) plus any lapse 
period months (July through September).  The 
Budget Year and the Fiscal Year correspond 
from September through June.  Daily receipt 
and expenditure transactions from July 01 
through June 30 are recorded in accounting 
periods 01 through 12 of the current Fiscal 
Year.  Transactions during lapse periods (July 
and August) can be recorded in either the 
previous Budget Year or the new Budget Year, 
but will always be recorded in the new Fiscal 
Year. 

Calendar Month A two-digit numeric for the calendar months, 
i.e. 01 for January, 02 for February, etc. 

Creation Date The date the MERLIN warehouse extracted the 
detail information from the source system 

Expense/Tax Indicator The travel field that indicates whether the 
earning code associated with the line amount is 
for an expense code (E) or for state and federal 
taxes (T). 

GAAP Adjustment Indicator 
 

An indicator stored in MERLIN that tells 
whether a specific transaction is a GAAP 
adjustment or not.  GAAP adjustments are 
made at year-end by the Auditor’s Office, 
normally in the thirteenth accounting period and 
is available through FY 2014. 
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GAAP (Generally Accepted Accounting Principles) 
The conventions, rules and procedures 
necessary to define accepted accounting 
practices at a particular time and is available 
through FY 2014. 

Lapse The legal termination of the unexpended 
balance of an appropriation at a specific point 
in time after the current Budget Year has 
ended, usually between July 1 and August 31 
of the new Accounting Year.   Lapse 
transactions were captured in SAAS the same 
as all other information (budget year, 
accounting year, and accounting month) and is 
available through FY 2014.  For example, any 
lapse transactions for the Budget Year 1999 
can be found by querying the data with budget 
year = 1999, accounting year = 2000, and 
the accounting month in (01, 02, 03). 

Non Bud Enc Encumbrances (account type code = 21) that 
are stored in MERLIN as non-budgeted.  An 
encumbrance is determined as non-budgeted if 
a budget was not established on SAAS’s FDBT 
table and the appropriation unit did not fall into 
the 8000 range.  Note: If an agency received a 
lump sum appropriation, but still established 
budgets on SAAS’s FDBT table, their 
encumbrances would be reflected in MERLIN 
as budgeted and is available through FY 2014. 

Non Bud Exp Expenditures (account type codes = 22, 23) 
that are stored in MERLIN as non-budgeted.  
An expenditure is determined as non-budgeted 
if a budget was not established on SAAS’s 
FDBT table and the appropriation unit did not 
fall into the 8000 range.  Note: If an agency 
received a lump sum appropriation, but still 
established budgets on SAAS’s FDBT table, 
their expenditures would be reflected in 
MERLIN as budgeted and is available through 
FY 2014. 

Travel Type There are three types of travel: in-state (0), out-
of-state (1), and out-of-country (2). 

Trip Number A 12-digit number used to track costs related to 
a trip.  The first four digits are the SAAS 
agency number, the fifth and sixth digits are the 
budget year and the last six digits are the 
SPAHRS travel system assigned number. 

Worker Type The identification of worker, may be PIN (P) or 
WIN (W). 
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COGNOS Impromptu Definitions 
 

Ad Hoc Report  A report that a user creates by adding the 
columns of choice along with filters, groups and 
formats. 

Associating Data Associating enables the user to further 
organize the data into logical chunks of 
information from within a data item that is 
already grouped.  There must be a one-to-one 
relationship between the two data items before 
the user should associate one data item with 
another.  Associating a data item removes the 
repeating data in the user’s report, eliminates 
duplication of data items and subtotals. (See 
Figure 3) 

Columns Columns are individual data items extracted 
from the catalog. 

Grouping Data Grouping enables to organize the data in 
logical chunks of information.  It allows the 
user to easily view the data by the items that 
are grouped and the report won’t duplicate 
values for the data item that the user has 
grouped.  (See Figure 2) 

Filtering Data Filtering enables the user to specify the 
conditions that must be met for data to be 
included in the report.  It focuses the report on 
the data that is important to the user and 
minimizes the processing time by excluding 
any data that is irrelevant to the report. (See 
Figures 4 & 5) 
 
NOTE: If you wish to select only one condition 
for an item to appear in the report, you will 
need to use the ‘=’ sign in your filter, i.e. Budget 
Year = ‘1999'.  If you wish to select more than 
one condition for an item to appear in the 
report, you will need to use the ‘in’ operator and 
parentheses for your filter, i.e. Budget Year in 
(‘1999', ‘2000'). 

Prompts Prompts are dialog boxes that ask the user to 
enter information when the report is first 
opened.  The prompt is a filtering tool that 
provides the user with the ability of easily 
changing filters prior to running a report. 

Save As When saving either a Standard Report that the 
user has modified or an Ad Hoc Report that the 
user has created, the user should always save 
the report in the My Reports folder. Click on 
File, then Click on Save As. 

 



4106 – MERLIN Addendums                                                                                   V3 08/08/2016 

_____________________________________________________________________________________________ 
 Page: 6 of 23 

Sorting Data Sorting enables the user to change the order of 
the alphabetical or numerical data items into 
either ascending or descending order, or works 
in addition to any grouping already established 
in the report. 

Standard Reports Developed by the MERLIN Team, a Standard 
Report is a structurally complete report, which 
contains columns of commonly, requested 
information.  When a Standard Report is 
opened, a prompt dialog box appears 
prompting the user to fill in variables for specific 
information. 

 
 

Figure 1, Report without Grouping or Association 
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Figure 2, Report with Grouping 
 

 
 

Figure 3, Report with Groupings and Associations 
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Figure 4, Filter Screen 
 

All reports should include filters for the Budget Year and the Agency Number.  There 
may be other filter criteria needed in the report.  It will be dependent on the type of 
question being asked or the specific information 

 

 
 

Figure 5, Filter for a Transaction Detail Query 
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Running an Ad Hoc Report and Getting the Desired Results: 
 

1. Decide on what is needed from the report. 
2. Decide on how the report needs to look. 
3. Complete the Cognos Report form at the end of this section. 
4. Write down the columns of data that are wanted in the report. 
5. Decide on which data needs to be grouped. 
6. Decide if it is necessary to associate any of the grouped items. 
7. Decide if it is necessary to sort any of the data. 
8. Decide on what filters are needed. 

(REMEMBER: Always filter on a minimum of two areas and always include the agency 
number and budget year.) 

9. Determine if it is best to open the report with a prompt every time. 
 
How to Disconnect From the Catalog and Edit Your Report: 

 
Impromptu allows you to disconnect from the catalog to make changes to a preexisting report 
and then run the changed report.  This provides you with the option to run only one report as 
opposed to running the first report, making changes to it, then running the report based on your 
changes.  To accomplish this procedure: 
 

1. Logon to Cognos and enter your MERLIN id and password then click OK. 
2. Open the report that you want to edit. 
3. Disconnect from the catalog by clicking on Catalog and selecting Disconnect from the 

Menu Bar. 
4. Make the changes to your report. 
5. To reconnect to the catalog click Catalog and select Connect from the Menu bar.  
6. Enter your user id and password and click OK. 
7. To run your new report and update the data, click on Report then select Retrieve. 
8. To save the new report, click on File then on Save As, and save your new report in the 

My Reports folder. 
 

 
 

 
 
 
 
 
 
 
 
 
 
 

 What do I want this report to show? 
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 Columns I will need: 
 

 Which columns do I want to sort? 
 

 Which columns do I want to group? (Grouping:  You may want to group data by 
agency name so that you can easily view your data by agency.) 
 

 How do I want to filter my report? (NOTE: You should filter your reports by at least 
budget year, Budget Year =1997, and one other criteria i.e. agency number) 

 
Improving Ad Hoc Reports Once Created: 
 
Add Filters: Use the filter toolbar button on the Power Bar to apply additional filters on one or 

more data items from the report’s columns or rows.  Select one or more values in a 
column.  Select a filter operator from the drop-down menu.  Note: The content of the 
drop-down menu varies depending on the selection the user made in the user column. 

 
Add Headers & Footers: Select a column or data item in the report and either click the header 

or footer toolbar button in the Power Bar. 
 
Move Columns: Select the column to be moved, move the user mouse pointer over the 

selected area until a four way arrow appears, click and drag the column to the point in 
the report where the columns need to be, then release the user mouse button.  Press 
ESC to clear the highlighting from the column. 

 
Delete Columns: Highlight either the column heading or a data item within the column and 

press the Delete key. 
Create A Prompt: From the Query Dialog box, create a filter using the Prompt Manager. Click 

New on the Prompt Dialog Box that appears.  In the Name Box, type in the prompt name 
as established by the user.  In the Type Box, select the type of prompt.  In the Message 
Box, type in the instructions a user would want to see in the Prompt Dialog Box that 
appears when the report is opened. 

 
Fit To Page: To automatically scale down a wide list report utilize the Fit To Page Option.  From 

the File Menu, click Page Setup.  In the List Frames Box, click the Fit To Page check 
box.  Click OK. 

 
Repeat Column Headers: Particularly useful when the report prints over subsequent pages 

because of the high number of columns represented.  Select one or more columns in the 
report.  Select Properties from the Format Menu, and click the Printing tab.  Click the 
Repeat This Column On Every Page check box.  Click OK.   

 
Inserting Data Into The Footer:  Provides the user with additional information, which assists 

the user in identifying subtotals.  After the footer has been created, select the data item 
you wish to add to the footer.  Drag the data item and drop it into the footer.  If you wish 
for the data item to also appear as a column in your report, select the Data Tab from the 
Query Dialog Box.  Select the data item that you wish to re-insert into your report and 
click ‘Mark for Insertion.’  Then click ‘OK’.  The column will appear at the end of the 
report and you may then reposition it where you want it to appear. 
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Inserting a Page Break in a List Report:  (NOTE: This option is not available if there are no 
groups in the report.) 

 

 Click on a grouped data item in the report. 

 From the Edit menu, click Select Parent. 

 From the Format menu, click Properties, then click the Page Breaks tab. 

 To set a page break before or after a grouped data item, click the Break Before or 
Break After check box. 

 To reset page numbers for one or more groups, click the Reset Page Number On 
check box and the group for which you want to reset the page numbering. 

 Click OK. 
 
To Edit Multiple Columns Easily: There area two ways to edit multiple columns of data to 

change the appearance of the data, i.e. font size, bolding, currency, etc.:  
 

To Edit a Series of Columns: 
 

 First, select the left most column that you want to begin editing by clicking on a 
data item in that column. 

 Using the arrow keys, scroll over to the right most column that you want to edit. 

 While holding down the Shift key, click your left mouse button to select all 
columns between your first selection and your last selection.  This will highlight 
all columns between the two points selected. 

 Make your changes, i.e. bold, font size. 

 Press the Esc key. 
 
 
To Edit Two or More Columns that are Not in a Series: 
 

 First, select the column that you want to begin editing by clicking on a data item 
in that column. 

 Using the arrow keys, scroll over to the next column that you want to edit. 

 While holding down the Ctrl key, click your left mouse button on another data 
item to select that column. 

 Repeat until all the columns that you want to edit are highlighted. 

 Make your editing changes, then press the Esc key. 
 
When to use Detail Data versus Summary Data: 
 
A user would use detail data when there is a need to generate reports, which contain specific 
transaction information, i.e. Transaction Codes or Numbers for designated Budget Years and 
accounting months. Detail data is available for each state agency by fund, and provides totals 
for each account, account type, and fund by transaction number. Detail data was updated daily 
after the SAAS nightly processing. This information is available through June 2014.    
 
A user would use summary data when there is a need to generate reports that summarize the 
data at a higher degree rather than at the transaction detail level. Information was updated 
monthly and daily from SAAS and is available through June 2014. 
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Explanation of the Relationships Between Transactions 
 
Purchase orders are created when an agency needs to order products or services.  When the 
products/services the purchase order (PO) was created for are received, a payment voucher 
(PV) is created.  There can be a one-to-many relationship between purchase orders and 
payment vouchers.  When a payment voucher hits the system during nightly processing, a 
warrant (AD) is created.      
 
1) If you have a warrant number and you want to know the purchase order it is associated with, 

here are the steps you need to take. 
a) You will run a transaction detail query.  (You can use the Transaction Detail Query 

standard report located in the History folder.) 
b) Open the report and enter the following information needed into the prompts:  enter ‘AD’ 

in the Transaction Type Code prompt and the warrant number in the Transaction 
Number prompt. 

c) The associated payment voucher (PV) number that the warrant is paying will be located 
in the Ref Transaction Number column. 

d) You can now rerun the Transaction Detail Query by clicking on the Prompt power bar 
button and input the payment voucher information. 

e) In the Transaction Type Code prompt, you will need to enter ‘PV’ and in the Transaction 
Number prompt, you will need to enter the number previously displayed in the Ref 
Transaction Number column in the first query. 

f) The information displayed in the Ref Transaction Number column in the second report 
will be the purchase order number. 

OR 
a) You will run the Warrant Number Query standard report located in the History folder. 
b) Enter the correct Budget Year and the Warrant Number in the prompt. 
c) Click ‘OK’. 
d) The associated payment voucher number will be located in the Transaction Number 

field. 
e) In order to find out the purchase order number associated with the payment voucher 

number, you will need to run a transaction detail query.  (You can use the Transaction 
Detail Query standard report located in the History folder.) 

f) In the Transaction Type Code prompt, you will need to enter ‘PV’ and in the Transaction 
Number prompt, you will need to enter the payment voucher number.  

g) The information displayed in the Ref Transaction Number column in the second report 
will be the purchase order number. 

 
2) If you have a warrant number and you want to know the payment voucher it is associated 

with, here are the steps you need to take. 
a) You will run a transaction detail query.  (You can use the Transaction Detail Query 

standard report located in the History folder.) 
b) Open the report and enter the following information needed into the prompts:  enter ‘AD’ 

in the Transaction Type Code prompt and the warrant number in the Transaction 
Number prompt. 

c) The payment voucher (PV) number that the warrant is paying will be located in the Ref 
Transaction Number column.  

OR 
a) You will run the Warrant Number Query standard report located in the History folder. 
b) Enter the correct Budget Year and the Warrant Number in the prompt. 
c) Click ‘OK’. 
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d) The associated payment voucher number will be located in the Transaction Number 
field. 
 

3) If you have a payment voucher and you want to know the purchase order it is associated 
with, here are the steps you need to take. 
a) You will run a transaction detail query.  (You can use the Transaction Detail Query 

standard report located in the History folder.) 
b) Open the report and enter the following information needed into the prompts:  enter ‘PV’ 

in the Transaction Type Code prompt and the payment voucher number in the 
Transaction Number prompt. 

c) The purchase order (PO) number that the payment voucher is issued against will be 
located in the Ref Transaction Number column.  

 
4) If you have a purchase order and you need to know the payment voucher associated with it, 

here are the steps you need to take. 
a) You will create a transaction detail query.  (You can use the Transaction Detail standard 

report located in the History folder.) 
b) Open the report. 
c) Click cancel when the prompt dialog box appears. 
d) Click Query from the Report menu. 
e) Click on the Filter tab 
f) You will need to delete two expressions from the filter.   

i) Click on Transaction Code to highlight it and delete the following expression:  
‘Transaction Code = ?Transaction Code?’ 

ii) Click on Transaction Number to highlight it and delete the following expression:  
‘Transaction Number = ?Transaction Number?’ 

g) Now you will create two new prompts.   
i) Double click Report Columns in the Available Components box.   
ii) Double click on ‘Ref Transaction Code’.   
iii) Double click on the = sign 
iv) Double click on Prompt Manager in the Available Components. 
v) Click ‘New’ on the Prompt Manager dialog box. 
vi) In the Name field, type ‘Ref Transaction Code’.  In the Type field choose, Type In 

from the drop down list box.  In the Message field, type in ‘Please enter the Ref 
Transaction Code.  USE ALL CAPS’. 

vii) Click ‘OK’.  Click ‘OK’ again. 
viii) Click ‘And’. 
ix) Double click Report Columns in the Available Components box.   
x) Double click on ‘Ref Transaction Number’.   
xi) Double click on the = sign 
xii) Double click on Prompt Manager in the Available Components. 
xiii) Click ‘New’ on the Prompt Manager dialog box. 
xiv) In the Name field type ‘Ref Transaction Number’.  In the Type field, choose ‘Type In’ 

from the drop down list box.  In the Message field, type in ‘Please enter the Ref 
Transaction Number.  USE ALL CAPS.’ 

xv) Click ‘OK’.  Click ‘OK’ again. 
h) An example of the ‘Filter Tab’ is shown below. 
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Figure 6, Filter Tab Example 
 

 
 

i) Click ‘OK’ at the Query Dialog box. 
j) If the Prompt Dialog box does not pop up after you have clicked ‘OK’, then click on the 

Prompt Power Bar Button.  
k) Complete the prompt by entering ‘PO’ in the Ref Transaction Code prompt and the 

purchase order number in the Ref Transaction Code Number prompt. 
l) The payment voucher number associated with this purchase order will be located in the 

Transaction Number column. 
 
5) If you have a payment voucher number and you want to know the warrant number it is 

associated with, here are the steps you need to take. 
a) You will create a detail query.  (You can use the Warrant Number Issued standard report 

located in the History folder.) 
b) Open the report and enter the information needed into the prompts. 
c) In this report, you will need to enter the payment voucher number in the Transaction 

Number prompt. 
The warrant number associated with the payment voucher will be located in the Warrant 
Number column. 

OR 
 

a) You can also follow the steps in example 4 listed above.  You will enter the ‘PV’ in the 
Ref Transaction Code and you will enter the payment voucher number in the Ref 
Transaction Code Number prompt. 
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b) The warrant number associated with the payment voucher will be located in the 
Transaction Number column. 

6) If you have a purchase order number and you want to know the warrant number it is 
associated with, here are the steps you need to take. 
 
a) You will create a transaction detail query.  (You can use the Transaction Detail standard 

report located into the History folder.) 
b) Open the report. 
c) Click cancel when the prompt dialog box appears. 
d) Click Query from the Report menu. 
e) Click on the Filter tab 
f) You will need to delete two expressions from the filter.  Here are the steps. 

 
i) Click on Transaction Code to highlight it and delete the following expression:  

‘Transaction Code = ?Transaction Code?’ 
ii) Click on Transaction Number to highlight it and delete the following expression:  

‘Transaction Number = ?Transaction Number?’ 
 

g) Now you will create two new prompts.   
 
i) Double click Report Columns in the Available Components box.   
ii) Double click on ‘Ref Transaction Code’.   
iii) Double click on the = sign 
iv) Double click on Prompt Manager in the Available Components. 
v) Click ‘New’ on the Prompt Manager dialog box. 
vi) In the Name field, type ‘Ref Transaction Code’.  In the Type field choose, Type In 

from the drop down list box.  In the Message field, type in ‘Please enter the Ref 
Transaction Code.  USE ALL CAPS’. 

vii) Click ‘OK’.  Click ‘OK’ again. 
viii) Click ‘And’. 
ix) Double click Report Columns in the Available Components box.   
x) Double click on ‘Ref Transaction Number’.   
xi) Double click on the = sign 
xii) Double click on Prompt Manager in the Available Components. 
xiii) Click ‘New’ on the Prompt Manager dialog box. 
xiv) In the Name field type ‘Ref Transaction Number’.  In the Type field, choose ‘Type In’ 

from the drop down list box.  In the Message field, type in ‘Please enter the Ref 
Transaction Number.  USE ALL CAPS.’ 

xv) Click ‘OK’.  Click ‘OK’ again. 
 

h) An example of the ‘Filter Tab’ is shown below. 
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Figure 7, Filter Tab Example 
 

 
 

i) Click ‘OK’ at the Query Dialog box. 
j) If the Prompt Dialog box does not pop up after you have clicked ‘OK’, then click on the 

Prompt Power Bar Button.  
k) Complete the prompt by entering ‘PO’ in the Ref Transaction Code prompt and the 

purchase order number in the Ref Transaction Code Number prompt. 
l) The payment voucher number associated with this purchase order will be located in the 

Transaction Number column. 
m) You will now use the Warrant Number Issued standard report located in the History 

folder to get the warrant number associated with the payment voucher number found in 
the previous step. 

n) In this report, you will need to enter the payment voucher number in the Transaction 
Number prompt 

o) The warrant number associated with the payment voucher will be located in the Warrant 
Number column. 
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Creating a Crosstab Report: 
 
A Crosstab report summarizes information in a concise table of rows and columns that shows 
the values at the intersection point of each row and column.  When you enter a data item into 
the Cells area, Impromptu automatically summarizes that item.  An example of this would be if 
you wanted to see a report of expenditures by major object and by month.  See figures 8 and 9 
below. 
  
To Create a Crosstab Report: 
 

1. Start the Report Wizard by selecting New from the File Menu. 
2. Select your template (except for blank) and select the button marked ‘Wizard.’ 
3. At this point, the Report Wizard will prompt you to enter a report name. 
4. Click ‘Next.’ 
5. Select ‘Crosstab Report’.  
6. Click ‘Next.’ 

 
At this point you will now add data items to your report by selecting which columns go in the 
Rows, Columns and Cells of the crosstab report. 
 

7. Enter at least one data item into the Rows area, one data item into the Column area, 
and one data item into the Cells area of a crosstab report.  

8. Enter a maximum of three data items in the Cells area of the crosstab report. 
9. Select data items that are only dollar amounts for the Cells area. 

 
Figure 8, Crosstab Query Dialog Box Example 
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Figure 9, Crosstab Report Example 
 

 
 

 
Creating a Summary Report 

 
You can create summaries in Impromptu to show a high level of information in your report.  If 
you want your report to contain only summarized information without details, you can create a 
summary using the Data tab (Query dialog box) as you create your report.  
 
To create a summary while creating your report: 
 
1. From the Report menu, click Query. 
2. From the Query dialog box, click the Data tab. 
3. Select the column that you want to summarize from the applicable folder in the catalog. 
4. Click the Summary button. 
5. Below is a sample of the Summary dialog box that appears. 
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Figure 10, Summary Dialog Box Example 
 

 
 

 
6. Click ...                                                                          To Calculate ... 

 

  

Total The total for the selected data items. 

Minimum The minimum value of the selected data 
items. 

Maximum The average of the selected data items. 

Average The average of the selected data items. 

Count The number of selected data items. 

Percent The percentage of the total that the data item 
represents. 

 
Note: The buttons available in the Summary dialog box depend on the data type of the selected 
column. 
 
7.  Click OK 
 

 If a summary is in the body of the list that is grouped, the summary is calculated for 
the lowest group in the list. 

 If a summary is in a list group header or footer, the summary is calculated for that 
group. 

 If a summary is in a form frame with the scope of the form frame set to a group, the 
summary is calculated for that group. 

 If none of the above is applicable, the summary is calculated for the entire report. 
 
 



4106 – MERLIN Addendums                                                                                   V3 08/08/2016 

_____________________________________________________________________________________________ 
 Page: 20 of 23 

Figure 11, Report without a Summary Example 
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Figure 12, Report With Summary Example 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Using HTML to Publish Reports on the Web: 
 
Publishing and distributing read-only Impromptu reports in Hypertext Markup Language (HTML) 
from your Intranet or Internet Web site or by email gives you and your users: 
 

 Reports that are ready for immediate viewing and printing agency wide. 

 Up-to-date information as they need it. 

 Reports that can be exported to Adobe PDF format or formatted Excel. 

 A single report that meets the needs of many different users.   
 
To Publish A Report as HTML: 
 
1) Make sure the report you want to publish as HTML is open and Page Layout view is 

selected. 
2) From the File menu, click Publish As HTML. 
3) In the Save In box, select the My Reports folder to save the HTML file. 
4) In the file prefix box, type in a meaningful name that you want as the prefix on all of the 

HTML files that will be created for this report. 
5) Click Options to specify Report Navigator options, or click Publish to create the HTML 

report using the default Navigator options.   
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The default Report Navigator options are: 
 

 put the Report Navigator in a separate frame. 

 include the page numbers in the published HTML report 

 publish all pages of the Impromptu report to HTML. 
 
6) Click OK. 
7) Click Publish. 
8) To preview the HTML report, double-click the file with the prefix you specified and the 

extension .htm. 
 
Enhanced HTML Support: 
 
You can enhance your report before publishing it as HTML to add more report details, link 
HTML reports, and provide users with additional functionality when they view the reports with a 
web browser.  For example, before publishing your report you can: 
 

 Include a hotlink that enables users to jump from the published HTML report to 
another web site. 

 Reference external HTML scripts. 

 Reference Java applets. 

 Embed Java script code directly in the HTML. 

 Include questionnaires and information requests in a report.   

 Put Web page locations in a database and join it to a report column. 

 
How to Set the Version When Saving a Report as an Excel 
Spreadsheet 
 
Cognos Impromptu (version 7.3) allows you to set what version of Excel a report is saved as, 
either 'Excel 2000' or 'Excel 2002 or higher' are the options.   
 
If you do not have the same version of Excel on your machine as what is set in the version box, 
then the report does not look accurate.  'Excel 2002 or higher' appears to be the default. 
 
If using Excel 2000, you must make sure that for each report you develop and save as an Excel 
spreadsheet that you set the version correctly.  Once it has been changed in the report and 
saved, there are no problems.   
 
Below are the steps to set the version: 
 

1. Open a report. 
 
2. From the Report menu, click Excel, and in the Version box, click the Excel version to 

use: 
 

‘Excel 2000’, or 
 
‘Excel 2002 or higher’   
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Note:  The following objects may be included with the ‘Excel 2002 and higher’ 
version by clicking the check box next to the object: 
 

 images 
 static charts 
 text frames 
 summary expressions 

 
3.  Click OK. 

 


