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Accessing an Impromptu Catalog 
 
A catalog contains all the information necessary for Impromptu to access and retrieve 
information from the data warehouse.  It contains information about what database to access, 
where the database is stored, and how the tables in the catalog are joined. 
 
To open a catalog 
 
When you initially start Impromptu and attempt to create a new report, you are automatically 
prompted to open a catalog. If you open an existing report, the catalog associated with that 
report opens 
 

 
 

Your Action… System Response 

1. Selecting the Catalog tab on the tool bar 
to Open or close a catalog. 

The Open Catalog screen will appear. 
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Connecting to Impromptu 
 

Your Action… System Response 

2. Select the appropriate catalog to access 
the data base. 

The Catalog Logon screen will appear. 
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Your Action… System Response 

3. Choose User from the user Class Drop 
down Menu.  

The Catalog Logon screen will appear. 

4. Enter Userid and Password under Data 
Base  

 

5. Choose OK. Once you have logged in to a catalog, you 
will remain logged in until you close 
Impromptu 

 
Building an Ad Hoc Report 
 
There might be times when there is not a standard report that satisfies your reporting needs.  In 
that case, you will need to build an ad hoc report.  You will start by creating a new report and 
adding the columns of your choice from the catalog.  You will then have the ability to set it up 
with your own groupings, filters, and format. 
 
Creating a New List Report 
 
A List report is a report made up of any number of columns.  New reports can be created by 
clicking the New button on the Power Bar.  It opens the default template which includes the 
State of Mississippi logo and is set up to print in landscape format 
 

Your Action… System Response 

1. Choose the New button on the Power 
Bar.  

The “Type the title of the report” screen will 
appear. 
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Your Action… System Response 

2. Choose Next.  The “What kind of Report would you like to 
create?” screen will appear. 

 

 
 

Your Action… System Response 

3. Choose Next. After creating a new report, the Query Dialog 
box opens automatically.  The Catalog box 
below shows the highest-level folders 
contained within the catalog. 

 
OR 

 
When a new report is created by selecting the File/New command, Templates can provide a 
head start with both the contents and the layout of a report.  With the Impromptu templates, a 
user can simply add the appropriate data to the template to create a report.  Several basic 
templates have been designed specifically for the State of Mississippi.  The default template on 
the palette is labeled Mississippi Landscape.  The Mississippi Portrait template also contains the 
log, but defaults to a vertical orientation.  The List Report template is blank (without a logo, 
header, or footers). 
 

Your Action… System Response 

1. Choose the File/New command.  A Palette window opens showing six 
templates. 
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Your Action… System Response 

4. Select OK.  After creating a new report, the Query Dialog 
box opens automatically.  The Catalog box 
below shows the highest-level folders 
contained within the catalog. 
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Users can now open many levels of embedded folders in the Catalog box to see the data items 
available for the report. 

 
 Description 

5. Select OK.  After creating a new report, the Query Dialog 
box opens automatically.  The Catalog box 
below shows the highest-level folders 
contained within the catalog. 

 
Folders--meaningful groupings of information (e.g., Budget Ledger Details, General Ledger 
Details) 
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Columns - individual items of information (e.g., Agency Name, Agency Number, Fund Name, 
Fund Number) 
 

 
 
Conditions - saved condition (e.g., Encumbrances) and calculation (e.g., Budgeted and Non-
Budgeted Expenditures) specifications 
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The Training Catalog 
 
During your Impromptu training, we will focus on financial information in the Training section of 
the catalog.  It is divided into three main folders – Fund/Object, Vendor/Fund/Major Object, and 
Code Tables.  As you examine the hierarchy, you will see layers of folders and within those 
folders, columns you will want to use for your reports.  Only columns at the very highest level 
are included in the following description. 
 

Folder:  Training 
Folder:  Fund/Object 

Folder:  Agency/Fund 
Folder:  Time 
Folder:  Account Codes 
Org Code 
Activity Code 
Bud Function Code 
Folder:  Dollar Amounts 
 Folder:  Expenditures 

Folder:  Encumbrances 
Folder:  Pre Encumbrances 

Data Source 
Folder:  Vendor/Fund/Major Object 

Folder:  Agency/Fund 
Folder:  Time 
Folder:  Account Codes 
Folder:  Vendor 
 Folder:   Vendor Addtl Info 
  Folder:   Vendor Minority Certifications 
Folder:  Dollar Amounts 
 Folder:  Expenditures 

Folder:  Encumbrances 
Folder:  Pre Encumbrances 

Data Source 
Folder:  Code Tables 

Folder:  Agency Info (SAAS) 
Folder:  Address 

Folder:  Provider Information  
 
Choosing the Data 
 
The Data tab in the Query Dialog box displays the contents of the catalog from which you can 
select the data items you want in your query.  You can select data items in the Catalog box and 
add them to the Query Data box by: 
 

 Dragging columns to the Query Data box 

 Selecting columns and choosing the Add button, or 

 Double-clicking a column in the Catalog box 
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The order of the columns in the Query Data box determines the column order in the report.  
Columns can be moved and dragged to another location within the Query Data box.  Columns 
can be removed from the query with the Remove button.  Columns can also be added that do 
not display in the report by selecting the column and choosing the Mark for Insertion button to 
toggle the insertion status to off. 
 
Exercise 1 
 
The purpose of this first ad hoc report, is to create a report similar to the Expenditures $ 
standard report.  The report should reflect expenditures greater than $10,000 for January 1997.  
It should be sorted by Bud Exp Amt and grouped by Agency name as shown below. 
 

Your Action… System Response 

1. Choose the New button on the Power 
Bar.  

The Impromptu Report Wizard box will 
appear. 

2. Choose Next.  The “What kind of Report would you like to 
create?” screen will appear. 

3. Select List Report and choose Next. After creating a new report, the Query Dialog 
box opens automatically.  The Catalog box 
below shows the highest-level folders 
contained within the catalog. 
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Your Action… System Response 

4. Add Columns to the report: 
 
Expand the Training folder. 
Expand the Fund/Object folder. 
Expand the Agency/Fund folder. 
Double click Agency Nm (SAAS) and 

Agency Nbr (SAAS) to add them to the 
Query Data box. 

Collapse the Agency/Fund folder. 
Expand the Time Period folder. 
Double click Budget Year, Accounting 

Month, and Allotment Period to add 
them to the Query Data box. 

Collapse the Time Period folder. 
Expand the Account Codes folder. 
Double click Minor Obj Code and Major 

Obj Code to add them to the Query 
Data box. 

Collapse the Account Codes folder. 
Double click Org Cd, Activity Code, and 

Bud Function Code, located under the 
Account Codes folder, to add them to 
the Query Data box. 

Expand the Dollar Amounts folder. 
Expand the Expenditures folder. 
Double click Bud Exp to add it to the 

Query Data box. 
Choose Finish. 

The report will appear. 
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Your Action… System Response 

5. Sort the Data by Budget Expenditure 
Amount in Descending Order. 
 
Select Report located on the Menu Bar. 
Select Query from the drop down menu. 

The Query dialog box will appear. 
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Your Action… System Response 

Continue. 
 

Select the Sort tab in the Query dialog 
box. 

The Query Sort tab screen will appear. 
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Your Action… System Response 

Continued. 
 
Select Bud Exp. 
Select the Descending button. 

 

6. Group the data by Agency and Major 
Object Code 
 
Select the Group tab in the Query dialog 

box. 
Select Agency Nm (SAAS). 
Select the Group button. 
Select the Agency Nbr (SAAS). 
Select the Associate Button. 
Double click on the Major Obj Code. 

 

 

 
 

Your Action… System Response 

7. Filter the data to Budget Year and 
Accounting Month. 

 
Select the Filter tab in the Query dialog 

box. 
Double click on the Reports Columns. 
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Your Action… System Response 

Continued. 
 
Double click on the Budget Year. 
Double click the =. 
Double click the string. 
Enter 1997. 
Click on the ...  
Double click on and. 
Double click on the Reports Columns. 
Double click Agency Nbr (SAAS). 
Double click the =. 
Double click the string. 
Enter 130. 
Click on the ...  
Double click on and. 
Double click on the Reports Columns. 
Double click Accounting Month. 
Double click the =. 
Double click the string. 
Enter 07. 
Click on the ...  
Double click on and. 
Double click on the Reports Columns. 
Double click on the Bud Exp. 
Double click the >. 
Double click the number. 
Enter 100000. 
Select OK. 

The report will appear. 

8. Modify the title in the List Header. 
 
Click on the List Report Title. 
Highlight the default text and delete. 
Enter Expenditures by Agency. 

 

9. Save the report. 
 

Select File from the menu bar. 
Select Save As and type My First 
Report for the file name. 
Select Save. 

The report will be displayed. 
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Creating a SmartSummary 
 
Summaries allow you to aggregate data at various levels within reports.  When you create a 
SmartSummary, the value that is calculated will reflect the group it is associated with. 
SmartSummaries are dynamic and are calculated based on their position in the report.  It will 
calculate a Monthly Total if you put it in the Monthly footer, and it will calculate the Annual Grand 
Total if you put it in the Grand Total footer.  When you make a new SmartSummary, a special 
SmartSummary icon appears below the group that the SmartSummary is associated with in the 
Group Order box. 
 
Adding Text Frames  
 
A group footer is automatically added for each distinct group within the report when a 
SmartSummary is created.  To label the footer, add a text frame to the footer.  To create a text 
frame: 
 

Your Action… System Response 

1. Click the Text Frame button on the Layout 
Power Bar.  

(The mouse pointer changes to a Text icon) 

2. Position the pointer where you want the 
upper-left corner of the text. 

 

3. Drag the mouse diagonally until it is the 
size you want. 

 

4. Release the mouse button.  

 
Exercise 2 
 
Create the following vendor payment report for one vendor for all periods in Budget Year 1997.  
Create a Monthly Total and Grand Total using the Smart Summary feature, and add text frames 

to label the totals. 
 

Your Action… System Response 

1. Choose the New button on the Power 
Bar. 

The Impromptu Report Wizard screen will 
appear 

2. Choose the Next button.  

3. Select the List Report and choose Next. The Catalog box showing the highest-level 
folders contained within the catalog will 
appear. 
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Your Action… System Response 

4. Add columns to your report. 
 
Expand the Training folder. 
Expand the Vendor/Fund/Major Obj 

folder. 

 

5. Add the following columns to the Query 
Data Box: 

 
Vendor Nbr 
Vendor Name 
Agency Nm (SAAS) 
Agency Nbr (SAAS) 
Budget Year 
Accounting Month 
Bud Exp 

 
 

6. Choose Finish. The report will appear. 

 

 
 

Your Action… System Response 

1. Sort the data by Bud Exp amount in 
descending order. 

 

2. Group the data by Agency Name (SAAS) 
and Accounting Month. 

 

3. Filter the data to the vendor name 
OFFICE DEPOT – JACKSON, Budget 
Year 1997, and Agency Number 651. 

 

4. Select OK. The following report will appear. 
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Your Action… System Response 

5. Edit and format the report  
 
Delete the Vendor Name column. 
Move the Accounting Month column 

next to the Agency Name column. 
Rename the Bud Exp Amt column to 

Expenditures. 
Make all Column heading bold by clicking 

on the first column and control click on 
the others to highlight. 

Select Bold on the Power Bar. 
Change the font to a larger size. 

The report will be displayed. 

 

 
 

Your Action… System Response 

6. Create a SmartSummary 
 
Select the Expenditures column. 
Select the Total power Button. 

The report will be displayed. 
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Your Action… System Response 

7. Insert the words Monthly Total in the 
group footer 
 
Select the Text Frame button on the 

Power Bar. 
Click in the footer. 
Drag the text frame icon to make a 

rectangle. 
Type Monthly Total. 
Highlight Monthly Total and select Bold 

on the Power Bar. 
Press the ESC Key. 

 

 

 
 

Your Action… System Response 

8. Add text frames for an Agency Total and 
a Grand Total. 

 

9. Modify the title.  

10. Save the report as My Second Report 
and close the report. 
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Creating a Filter with the PowerButton 
 
Use the filter button on the Power Bar to quickly perform simple filter operations such as 
showing Vendor Payment Hold indicated with a “Y.”   To create a basic filter using the Power 
Bar button: 
 

Your Action… System Response 

1. Select a data item or CTRL + click to 
select multiple items. 

 

Click the button on the Power Bar. 
 

 
Impromptu retrieves records based on the data values you selected; all other data is filtered out 
of the query. 
 
More Easy Ways to Create Filters using the PowerButton 
 
The filter power includes a drop down button that allows you access to a variety of filter options 
from the filter definition dialog box.   
 

Your Action… System Response 

1. Select one or more values in a column.  

2. Select the Filter drop-down button. A drop-down menu will appear. 

 

 
 

Your Action… System Response 

3. Select a filter operator from the 
drop-down menu: 

 
To filter on the selected values, select In. 
To filter out the selected values, select 

Not In. 
To filter the selection on a given range, 

select Between. 
To filter out the selection on a given 

range, select Not Between. 
To filter the selection based on one or 

more values, select an operator such as 
=, <>, <, <=, >, >=. 

Note:  The contents of the Filter drop-down 
menu vary depending on the columns you 
select to filter on. 
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Your Action… System Response 

4. Position the cursor over the arrow that 
appears at the right of the drop-down 
menu. A fly-out menu appears. 

 

5. From the fly-out menu that lists available 
options, do one of the following: 

 
To filter a report on one or more data 

items currently highlighted, select 
Selection. 

To enter one or more numbers upon 
which to filter, select Number. 

To enter one or more text strings upon 
which to filter, select String. 

To enter one or more dates upon which to 
filter, select Date. 

To enter one or more times upon which to 
filter, select Time. 

To enter a date and time variable upon 
which to filter, select Date-time. 

To enter one or more intervals upon 
which to filter, select Interval. 

Note:   The contents of the Filter fly-out 
menu vary depending on the columns you 
select to filter on. 
 

6. If you chose 
 

Selection - the filter is automatically 
applied to the report. 

String - the String dialog box appears, 
where you can enter or select the 
required item or items and select OK. 

Select Values - a Select Value dialog box 
appears, where you can select the 
required item from the list provided. 
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Creating a Calculation 
 
A calculation is an expression that calculates a new data item based on existing data items.  For 
example, you can define a calculation that creates a column summarizing Bud Exp Amt and 
Non Exp Amt.  To create a calculation, select Calculation from the Insert menu and place the 
pointer at the new column location.  A Dialog box opens with options for entering the Name and 
the calculation expression.  Components you can use in the expression are listed in the Options 
box.  Operators that you can use in the expression are below the Expression box as buttons.  
Use the Delete or Backspace key if you make a mistake. 
 
Fit a Wide List Report to a Page  
 
You can automatically scale down a wide list report by utilizing the “Fit to page”option.   
 

Your Action… System Response 

1. Choose Page Setup from the File menu. The Report Properties box will appear. 
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Your Action… System Response 

2. In the List Frames Box, select the “Fit to 
page”and select OK. 

Helpful hints: 
 

 “Fit to page” does not affect the Page 
Layout view or Screen Layout view of 
a report. 
 

 “Fit to page” scales down a wide list 
report while maintaining the 
horizontal/vertical ratio. 
 

 “Fit to page” should not be used with 
the Repeat This Column on Every 
Page option. 
 

 “Fit to page” check box is available 
only when working with a list report. 

 
Repeat Column Header on Each Page  
 
If you allow a report to print over subsequent pages, the column information can lose its context.  
In such a case, you can repeat column heading on subsequent pages so that the data retains 
the desired context.   
 

Your Action… System Response 

1. Select one or more columns in your 
report. 

 

2. Choose Properties from the Format menu 
and select the Printing Tab. 

The Text Properties box will appear. 
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Your Action… System Response 

3. Select the Repeat this column on every 
page and select OK. 

 

 
Insert a Report Header on Each Page 
 
You can easily have a report header print on each page of the report when needed for a point of 
reference by following these steps: 
 

Your Action… System Response 

1. Choose Page Layout from the View 
menu. 

 

2. Choose Boundary Lines from the View 
menu. 

 

3. Choose Zoom from the View menu. The Report Properties box will appear. 

 

 
 

Your Action… System Response 

4. Select the Whole page and select OK.  

5. Choose Page Setup from the File menu.   
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Your Action… System Response 

6. Select Page Header and select OK.  

7. Select the Header area of your report and 
click and drag to enlarge the Header 
area. 

 
If your report does not have a text box 

with header information create a text 
box for you report header. 

If your report already has a text box with 
header information, and you want the 
text box to appear in the header, simply 
select the text box and drag into the 
header area.   

Other objects, such as the State of MS 
seal may also be added to the header 
by selecting the item and dragging it to 
the header area.   

Once you have moved items to the 
header, you may delete the box by: 
Selecting the area where the report 

text box header information was 
moved from (this will highlight the 
area). 

Depressing the Delete key 

 

8. Return report to its original layout.  

9. Choose Screen Layout from the View 
menu. 

 

10. Choose Boundary Lines from the View 
menu. 

 

11. Choose Zoom from the View menu and 
select 100%. 
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Exercise 3 
 
Create a Vendor Report to show only vendors with a Payment Hold of Y for Fund Numbers 
3400 and 3408.  Include subtotals and totals of Budget Expenditure Amount and create a 
column for Total Expenditures.  Your report should appear as shown below. 
       

Your Action… System Response 

1. Select New button on the Power Bar.  

2. Add columns to the report from the 
Vendor/Fund/Major Obj folder: 

 
Agency Nm (SAAS) 
Agency Nbr (SAAS) 
Fund Number 
Budget Year 
Vendor Name  
Vendor Nbr 
Vendor Payment Hold Ind 
Bud Exp  
Non Bud Exp 

 

3. Group the report by: 
 

Agency Nbr (SAAS) 
Associate Agency Nm (SAAS) 
Vendor Nbr 
Vendor Name 

 

4. Filter the report so that only vendors with 
a payment hold indicated by Y are 
reported for Budget Year 1997, Agency 
Number 401. 

 

5. Select OK to retrieve the report. The report will be displayed. 
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Your Action… System Response 

6. Filter the Fund Number for 3400 and 
3408. 
 
Select 3400 in the Fund Number column. 
Control Click to select 3408 in the Fund 

Number column. 

Select the  
Select down error from the drop down 

menu and choose In. 
From the fly-out menu, choose Selection. 

The following report will appear. 

 

 
 

Your Action… System Response 

7. Insert footer and create a subtotal by 
Vendor. 
 
Choose a value under Vendor Number 

column. 

Choose the Footer button  on the 
Power Bar. 

Choose a value on the Bud Exp Column. 

Choose the Total button  on the 
Power Bar. 

 

8. Add a text frame for the Subtotal footer.  
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Your Action… System Response 

9. Create a calculated column to sum the 
two Expenditures columns. 

 
Choose Calculation from Insert menu. 
Click to the right of Non Bud Exp. 

The Calculation Definition box will appear. 

 

 
 

Your Action… System Response 

Continued. 
 
Type Total Expense in the Name box. 
Open Report Columns. 
Double click the Bud Exp. 
Double click the + sign. 
Open Functions. 
Double click if null-numeric. 
Open Report Columns. 
Double click Non Bud Exp. 
Double click number. 
Choose OK. 

The report showing the Total Expense 
Column will appear. 

10. Delete the Agency Nbr (SAAS) and 
Budget Year columns. 

 

11. Move the Fund Number column to the 
right of the Vendor Nbr column. 

 

12. Add the title Vendor Payment Hold 
Indicator Report. 
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Your Action… System Response 

13. Save report as My Third Report and 
close report. 

 

 
Aligning Objects in a Report 
 
When footers are added to a report, there is an easy way to align data items.  After choosing 
Align from the Format menu, a Dialog box opens.  Select the Align tab.  There is a Vertical box 
for setting the vertical alignment of the report objects and a Horizontal box to set the horizontal 
alignment of the report objects.   
 
Exercise 4 
 
Create a report for Wildlife Fisheries and Parks showing expenditures grouped by funds for 
budget year 1997.  Include totals only for each fund and a grand total.   
 
Note:  You will receive a warning on this exercise about exceeding the 10,000 rows limit.  When 
you receive this warning, click Yes to continue. 

 
Your Action… System Response 

1. Choose the New button on the Power 
Bar. 
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Your Action… System Response 

2. Add the following columns to the report 
from the Fund/Object folder. 

 
Agency Nbr (SAAS) 
Agency Nm (SAAS) 
Fund Name 
Fund Grp Type 
Fund Number 
Budget Year 
Major Obj Code 
Bud Exp 
Non Bud Exp 

 

3. Filter the report by: 
 

Agency Number = 464 
Budget Year = 1997 

 

4. Group the report by Fund Name and by 
Major Object Code. 

 
Choose OK. 

 

5. Delete the Agency Nbr (SAAS), Agency 
Nm (SAAS), Fund Number, Budget 
Year and Non Bud Exp columns. 

 

6. Format the report. 
 

Click a value under Bud Exp. 
Choose Data from the format menu. 
Choose #,##0.00 from the Positive drop 

down menu. 

 

7. Create a Total for each Fund. 
 

Click on a value under Fund Name. 
Click Footer on the PowerBar. 
Click a value under Bud Exp. 
Click the Total button on the PowerBar. 

 

8. Align the Total. 
 

Highlight a Total value. 
Choose Align from the Format Menu. 
Click the first drop down menu in the 

Horizontal Alignment drop down box 
and review the selected alignment. 

Click OK. 

 

9. Save and Close The following report appears. 
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